To prevent the reverse engineering of script apps, numerous developers encrypt their program code with instruments such as ionCube PHP Encoder and make it human unreadable. The aforementioned is valid for paid applications in particular, because anyone would be able to use and change the unprotected code without having to pay the needed license fees. When you get web software protected with ionCube PHP Encoder, you will be able to use it without a problem as long as a tool known as ionCube Loader is present on the hosting server. This loader enables you to run encrypted files and you will often find it on the list of prerequisites for a given script app to be installed. Due to the fact that the encrypted files are already precompiled, they are generally executed a lot faster and this will improve the overall speed of your website.
IonCube in Cloud Hosting
IonCube Loader is provided with all of the cloud hosting plans that we supply, so every time you need it to set up and execute some script app that needs it, you can activate it with a single click in the Advanced area of the Hepsia Control Panel. Due to the fact that you'll be able to change the PHP release that is active for your account in the same section, you will have to enable the instrument for every new version that you set. When you are more experienced, you're able to employ a php.ini file in a domain or subdomain folder and set both the PHP version as well as the status of ionCube Loader for this particular website only, without affecting the whole account. Thus you'll be able to run both new and older script apps for multiple sites inside the same account - something that you can't do with lots of other hosting providers on the market.
IonCube in Semi-dedicated Servers
Since all semi-dedicated server accounts are set up on our advanced cluster platform and ionCube Loader is available on it, you will be able to use any script app that requires the software tool so as to work efficiently. With just a few clicks in the Hepsia website hosting Control Panel you'll be able to activate or deactivate ionCube for the PHP version which is currently active for the account. Since we support a couple of versions of PHP at the same time, you'll need to do that any time you move to a different release, and if you revert back to a release which you've already used, our system will remember your preference and ionCube Loader will already be activated. In case you have multiple websites inside the same account and they need different releases of PHP, you're able to set up a php.ini file in each and every domain folder and with a couple of lines of program code you're able to define both the PHP release as well as the status of ionCube irrespective of what is selected for the web hosting account as a whole.